Get Runbooks Doesn't Return Anything

Sep 19, 2012 at 8:21 PM

I'm using the 'SCORCHDev - Orchestrator' IP and am having trouble getting any of the activities to return anything. For instance, the 'Get All Folders' activity doesn't error when it runs, but it doesn't have any results. In the config I verified that the URL in there is reachable, and I am using the Orchestrator service account for the user. I tried changing the config PW to something I know is bad to verify this wasn't an authentication problem, but that returned an error as expected.

If I try the "Get Runbook Job Instance Details" activity (with the path triple-checked), it gives an error:

Runbook Not Found:  
Exception: ExceptionTarget site: SCOrch.getRunbookJobInstances
Stack trace:   at OrchestratorInterop.SCOrch.getRunbookJobInstances(OrchestratorContext sco, String runbookPath)   at OrchestratorIP.Activities.GetRunbookJobInstanceDetails.Execute(IActivityRequest request, IActivityResponse response)

Any ideas?

Sep 28, 2012 at 9:43 PM

Thanks so much to Ryan, we got this working!

The issue was a permissions problem. The account I was using in the Pack Configuration was the service account for Orchestrator, which apparently didn't have permissions to read items from the web service (in the Get Folder activity case it's trying to go to "http://servername/Orchestrator2012/Orchestrator.svc/Folders"). I granted access to the service account at the root (and it inherited down through all the folders), cleared the web console cache, and re-ran the activity and it worked perfectly.

Thanks again, hope this helps if someone sees a similar issue.